What is CVE-2023-51702?A medium-severity flaw in Airflow, explained.
CVE-2023-51702 is a medium-severity flaw (CVSS 6.5) in Airflow from Apache, published on 24 January 2024. It is not on the list of flaws known to be exploited today. The latest forecast puts its chance of use in the next 30 days at 0.4%. If you run an affected version, plan in the vendor’s fix.
Published 24 January 2024. Record last updated 11 June 2025. We keep this page's data up to date.
What is CVE-2023-51702? In plain terms.
It can be attacked from anywhere on the internet with an ordinary user account, and nobody has to click anything. If it works, the attacker can read data.
Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this configuration file as a dictionary and sends it to the triggerer by storing it in metadata without any encryption. Additionally, if used with an Airflow version between 2.3.0 and 2.6.0, the configuration dictionary will be logged as plain text in the triggerer service without masking. This allows anyone with access to the metadata or triggerer log to obtain the configuration file and use it to access the Kubernetes cluster.
This behavior was changed in version 7.0.0, which stopped serializing the file contents and started providing the file path instead to read the contents into the trigger. Users are recommended to upgrade to version 7.0.0, which fixes this issue.
What kind of flaw is it?
- CWE-532Insertion of Sensitive Information into Log File
- CWE-312Cleartext Storage of Sensitive Information
How an attack on it works
Read straight from its severity rating, translated out of the shorthand.
- Where an attacker can beAnywhere on the internet
- How hard it is to pull offEasy: no special conditions
- Login needed firstAn ordinary user account
- Does someone have to clickNo, nobody has to do anything
- What an attacker getsCan read data
Severity vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Is CVE-2023-51702 being exploited? Not that we know of.
It is not on the list of flaws known to be exploited today. The latest forecast puts the chance of it being used in the next 30 days at 0.4%. That can change at any time, which is why we keep watching.
Timeline
- Published
- Record last updated
CVE-2023-51702 scores 24. Action: Monitor.
We keep the score of every published flaw up to date as the evidence changes. Four things go into the score, and evidence that criminals are actually using it counts most. In order:
- Evidence it is being exploitedBiggest factor
- How severe it isStrong factor
- How widely exposed it isKey context
- Real threat activity around itKey context
85 and above is Critical. Anything confirmed as exploited is always marked for an emergency patch, whatever its score.
When CVE-2023-51702 matches software you track, it lands in your list with its score and the reasons behind it.
See your own ranked list →Who is affected by CVE-2023-51702? 2 products.
The published record lists 2 products from 1 vendor. Versions are shown as published: "2.3.0 to before 2.6.1" means from 2.3.0 up to, but not including, 2.6.1. If you run one of these, check your version, then go to the fix below.
- Application
Airflow
by Apache
Affected versions2.3.0 to before 2.6.1 - Application
Airflow Cncf Kubernetes
by Apache
Affected versions5.2.0 to before 7.0.0
How do I fix CVE-2023-51702? Four steps.
- Check whether you run itCompare your versions with the affected products above. Not sure what you run? EdgeProtect can work it out from your public website, or you can pick it from a list.
- Apply the vendor’s fixInstall the update named in the vendor’s advisory. We’ve put the advisories and patch notes first in the list.
- If you can’t patch todayFollow any mitigation the vendor publishes, and limit who can reach the affected system from the internet until the update is in.
- Keep an eye on itTrack the product and we tell you as soon as we spot this flaw on the list of exploited flaws, or a jump in its exploit likelihood.
References
5 links- apache/airflow pull request (opens in a new tab)github.com
- apache/airflow pull request (opens in a new tab)github.com
- apache/airflow pull request (opens in a new tab)github.com
- 89x3q6lz5pykrkr1fkr04k4rfn9pvnv9 (opens in a new tab)apache.org
- oss-security mailing list post, 24 Jan 2024 (opens in a new tab)openwall.com · 2024
Does CVE-2023-51702 affect you? We'll keep checking.
Looking flaws up one at a time doesn't scale. Tell us what you run once, and we tell you which flaws matter to you, in what order, and keep watching for new ones.
- Tell us what you runPick your software from a list, or let us work it out from your website.
- We match it to every flawOver 400,000 published flaws, checked against your list.
- Ranked by real-world riskA 0 to 100 score, led by evidence criminals are using it.
- Told as soon as we knowAn alert by email, in the app or by webhook to your own tools.
Free plan, no card needed. Nothing to install.
1 new flaw affects software Acme tracks
Since version 5.2.0, when using deferrable mode with the path of a Kubernetes configuration file for authentication, the Airflow worker serializes this confi...
- Matched to
- Airflow on Acme's software list
- What to do
- Plan in the vendor’s update
Sent to the alert recipients Acme chose. Also in the app and to Acme's webhook.
CVE-2023-51702 is a medium-severity flaw in Airflow from Apache, published on 24 January 2024. It can be attacked from anywhere on the internet with an ordinary user account, and nobody has to click anything. If it works, the attacker can read data.
It scores 6.5 out of 10 on the CVSS severity scale, which is medium. Our risk score for CVE-2023-51702 is 24 out of 100, which is Low. Its action is "Monitor". No sign of exploitation and a low forecast. Patch it in your normal update cycle.
It is not on the list of flaws known to be exploited today. The latest forecast puts the chance of it being used in the next 30 days at 0.4%. That can change at any time, which is why we keep watching.
For Airflow from Apache: 2.3.0 to before 2.6.1. The record lists 2 products in all, each with its versions, under "Who is affected" on this page.
Install the update the vendor names in its advisory, linked first under "How do I fix" on this page. If you can't patch today, follow the vendor's mitigation and limit who can reach the affected system from the internet.